KooZic : sortie de la v2.1.0

Après un changement majeur d'interface en v2.0.0, KooZic se socialise avec la prise en charge des événements musicaux. C'est aussi la première version avec l'intégration de LDAP.

Concerts et événements

La grosse nouveauté de cette version est l'ajout d'une partie sociale à KooZic via la récupération des concerts des artistes. Il est possible de mettre à jour les événements liés à un artiste à partir de sa fiche, dans l'onglet "Événements". De plus, chaque utilisateur peut suivre les artistes de son choix via le bouton "Suivre", en haut à droite.

Les événements liés aux artistes suivis sont agrégés dans le menu supérieur "Événements". Par défaut, ils sont groupés par mois, ce qui permet d'avoir une vue d'ensemble assez rapidement.

Finalement, il est également possible de définir la distance maximale à laquelle un événement se produit pour qu'il soit affiché dans cette liste. Chaque utilisateur peut modifier ses préférences (à partir du menu tout en haut à droite), et indiquer son emplacement et la distance maximale autorisée.

Amélioration de l'UI

Un des problèmes d'interface de KooZic est le nombre de clics nécessaire avant de jouer un titre. Il faut ajouter les piste dans une liste de lecture, puis lancer. C'est parfois pénible, mais jusqu'à présent je n'avais pas trouvé de bonne solution. C'est maintenant chose faite, des boutons "Ajouter et jouer" on été introduits un peu partout.

Un tel bouton a pour effet d'ajouter les pistes de l'album à la liste de lecture courante, et lancer sa lecture.

Intégration avec LDAP

Il est possible d'intégrer les utilisateurs KooZic avec un annuaire LDAP. Pour cela, il faut tout d'abord installer le module approprié via le menu "Applications" : "Authentification via LDAP".

Ensuite, il faut configurer le serveur dans les Paramètres, menu "Utilisateurs et sociétés > Serveurs LDAP". Un exemple de configuration est présenté ci-après avec un serveur de test.

Autres Nouveautés

Le lecteur vidéo Clappr a été mis à jour, avec une nouvelle gestion des sous-titres (support des SRT et WEBVTT).

Mise-à-jour d'une installation existante

La v2.1.0 est compatible avec la version précédente. Pour mettre à jour :

curl https://raw.githubusercontent.com/DocMarty84/koozic_install/v2/koozic_install.py > k_install.py
chmod +x k_install.py
sudo ./k_install.py upgrade

Notes :

  • Une nouvelle librairie est nécessaire : sudo pip3 install webvtt-py==0.4.2
  • Pour installer le module LDAP, il faut tout d'abord recharger la liste des modules manuellement. Aller à http://localhost:8069/web?debug, puis "Applications" et "Mettre à jour la liste des Applications"

N'hésitez pas à soumettre un problème sur Github si nécessaire !

Vus : 107
Publié par Marty : 49